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SPM Quick Tip - Setting the
Stereo Window

When you look at a stereo image, the edge of the image makes

an apparent “window” through which you see the image’s depth.

Setting the window means to move the apparent location of the

image forward or back by moving the left and right images closer

together or farther apart.  This is done in StereoPhoto Maker by

using the left and right arrow keys on your keyboard. Using the

right arrow key appears to move the image farther back.

The most important

reason to set the

window is to make

sure that everything

that should be behind

the window appears
that way. If something

that should be behind it appears to be located in front of the

window (farther forward than the window’s edge), that will cause a

“window violation” which spoils the 3D effect.

If you are not good at seeing window

violations, just remember that the Left

image sees Less on the Left (the 3-L

Rule). This means that you should be

seeing less of any object on the left

side of the left image than what you can

see in the right image.

For example, note that the window frame in the right image is not

visible in the left image because it sees less of the left side. Just

make sure when you set the stereo window that anything touching

the edge of the image is farther back (farther left in the left image)

than the edge itself.  Use the arrow keys to move the image back

(right arrow) or forward (left arrow).    [    ][    ]

by Dennis Green
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SPM Quick Tip: Auto-Alignment
by Dennis Green

One of the most valuable functions of StereoPhoto Maker, and the

one that established it as the most-used stereo image editor, is

the auto-alignment tool.  Prior to SPM, there were no stereo

digital cameras, so digital 3D was created by scanning film chips

(usually individually), using images from twin digital cameras

(which were often not aligned themselves) or by taking cha-cha

images from a single digital camera.  Using twin cameras often

resulted in images that were different sizes, due to zoom lenses

not being at the exact same focal length. SPM was created by

Masuji Suto to correct issues with digital stereo images.

SPM’s auto-alignment first analyzes both images of a pair to find

similar points in each image, then calculates whether one image

must be resized to match the other, as well as correcting vertical

misalignment from one camera being tipped up or down, and any

rotational or keystone error.  Even stereo digital cameras like the

Fuji W3 or Panasonic 3D1 can have minor misalignments.

To use the auto-alignment

feature, just open an image

and select Adjust -> Auto

Alignment (or the shortcut

Alt+A).  SPM will take a few

seconds to do the alignment

and then give you a report of

what changes were made.

You can align a whole folder

of images by using the Multi-

conversion feature.  In fact it

is a good idea to do that before viewing a session’s images to

save yourself any eyestrain from viewing many misaligned im-

ages. The images can be saved in .tiff or lossless .jpg format in a

separate folder to keep the originals untouched.     [    ][    ]

SPM Quick Tip: 3D Mirror Effect
By Dennis Green

Here is a way to use the 3D Mirror Effect tool to create some

interesting variations on images you may already have.

First open an image in SPM and

press [Ctrl] + W to get the horizon-

tal mirror tool.  Place the vertical

line at the point you would like to

be in the middle of the mirrored

image, then drag in the direction

of the part of the image you want

to keep.  In this example, the line

is on the right and I am dragging

to the left.

You will then get a hori-

zontally mirrored image:

Repeat that action using

[Alt] + W (the vertical

mirror tool) and placing

the line near the bottom,

then dragging up.  You will then get an image with some interest-

ing added features.  It works best when the intersection lines are

at the window (as opposed to being in the background).  Here is

my resulting image (in 3D):

It’s hard to believe this came from that first image!    [    ][    ]
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SPM Quick Tip - How To Save
EXIF Information - and Why
by Dennis Green

Exif data is the information in a digital photo about how the

image was taken. Right click on any image file, go to the bottom

and select “properties”.  You will find a long list of details, which

includes the date taken, the camera used, all of the settings, and

a lot of other details.  These screenshots show just part of the list

for an image out of the camera, and for one manipulated and

saved under another title. The information can be lost.

Linda Nygren shared information on how to keep this information

in modified files so you can get all the details about the final

image in the future.

“When you first run the SPM program, there are a few things in

the ‘preference settings’ that are important. First, you want to

make sure that SPM keeps your original image metadata, such

as time and date of capture and camera ID and settings. To do

this, go to *Edit *> *Preferences*, and near the bottom check the

box for ‘When add thumbnail image to Save file, copy original

exif to Save file’.

Original image file Resaved image file

17

If your imported image is 3D using  separate L and R images, SPM

automatically detects this and adds the image to the original in 3D.

You can then change

the size of the im-

ported image and

move it in all three

dimensions to get it

just where you want it

using the “image

position section.  For

the X and Y positions,

you can move the image around with your cursor, then use the up

and down arrows on the “Depth” box to move it forward and back.

You can use the “Repeat” button to bring in multiple copies of the

image, resizing and placing each copy independently.  You can

adjust the placement, including the depth, of several added image

components to make a new image with all of the elements in 3D.

Grab a pair of anaglyph glasses to view this image in stereo. Note

that extracting the black background allows the background items in

the new image to show through the wings of each fairy, greatly

increasing the realism of the new image.

Full instructions for using this feature can be found at:

http://www.stereomaker.net/eng/stphmkr/help/edit_13.htm
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“Then after you open an image, click on ‘file’ > one of the ‘Save’

options, then in the dialog box that opens up, check the box in front

of ‘Add thumbnail image to Save file’. You only have to do this

once, and SPM will continue to keep your original image

metadata.

“If you do NOT do this, then each new edited file will be treated as

if it were created on the day of editing and the details of the

original capture (EXIF data) will be lost. While you are in that

‘Save’ dialog, you can also choose the ’jpg quality’ which will be

remembered until you change it. The default is 70 or 80, but most

users prefer to set this at maximum while editing, which is ‘99’ for

SPM. It is mostly a concern if you might be saving your images

more than once, and wish to avoid the adverse effects of repeated

jpg compression.” [    ][    ]
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SPM Tip: Add A Component Image

Some very creative images can be made by using the “Add Logo

Image” command under the Edit menu to add image components

into a stereo image.  Photoshop has ways of removing a back-

ground from an image component, but placing it in a stereo image

is not always easy (and you have to have Photoshop). With SPM

you can bring in multiple images and extract their black or single-

colored backgrounds (i.e. the “green screen” process).

First, you open an image and then add another image to it.  You can

then use the “Extract” button and the eyedropper to select the back-

ground of the imported image to make it transparent.
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SPM Quick Tips - Creating an
Image Gallery
by Dennis Green

Creating an image gallery with SPM will allow you to share a

group of images with friends, relatives or the world in a way that

will allow them to view the images in whatever way they would

like. The user has the choice of several 3D modes including

parallel and cross-view for free viewing or using a screen viewer,

three anaglyph modes for viewing with red/cyan glasses, inter-

laced mode for use with a 3D monitor or 3D laptop, and a

squeezed mode (SBS50) for viewing on a 3D TV.

It even has the choice of viewing in 2D for someone who does

not have any 3D viewing options or who prefers 2D images.  It

has a slideshow option, as well as allowing you to step through

the images manually using the Left and Right arrow keys.

Once created, the gallery can be uploaded to a website, or it can
also be copied to a CD or sent over the internet using a program

like “WeSendIt”.  The nice thing about the gallery is that the user

does not need to install any program on their computer (not even

SPM) - it runs in whatever browser they already have!

Here’s how to create the gallery in a few minutes:

1. Put all of the images you want included in a single folder.

2. Open StereoPhoto Maker.

3. In the “web” menu,

select “Make HTML5

Stereo Viewer...”
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in the order they are picked.  You can even go to other folders and

pick images to add to the show, and SPM will remember where

each picture is located.  To create a different show, press Ctrl+M.

To run the slideshow when you are done, press Ctrl+Shift+O (or

go to File->Slide Show List->Open Slide Show List). You will see all

the lists in that folder, or you can change to another folder.  After you

pick the list, SPM will open the first image.  To start the show, just

press “A”.  Press “A” any time during the show to pause.

To remove an image from the show list while viewing the slide

show, press Ctrl+D.  You can fill the screen by pressing Enter or

Return, and toggle back out of full screen by pressing them again.

You can edit the slideshow easily by pressing Ctrl+Shift+H (or go

to File->Slide Show List->Edit Slide Show List). SPM will open the

text file that runs the show.  You can change any of the parameters

to get the result you want.

In the text file above, the first parameter is the image input format.

11 is side-by-side.  A few other common formats are:

13..Interlaced

14..Anaglyph

21..Independent L/R images.

The second parameter is the length of time that image will be

displayed in tenths of a second (so 30 = 3 seconds).  You can have

each slide displayed for a different amount of time if you want some

to be on screen longer than others.

The third parameter allows you to swap the L/R images to view

them with the cross-view method by changing the 0 to 1.

These have been tips for a simple slide show. You can create a

more complex show that includes a music file or comments dis-

played on the screen. That may be a future Quick Tips article.
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4. Navigate to the folder of

images you created. If you

want an index page with

thumbnail images, check

the thumbnail box at the

bottom. Change the name

in the Page Title box to the

one you want. For this

example we’ve used

“DSS Sample Images”

5. Select the images you want displayed and click “Start Selected

Files”, or if you want all of them, click “Start All Files”.

6. That’s it!  Your folder will now have

several additional files in it.

Double click on “index.htm_m” to view the

index page, or on “index.htm” to go

directly to the gallery.

Here is what the

index page will

look like, with

your page name

at the top.

And here is the viewer

in full screen mode

showing one of the

images (in parallel

mode) with the small

menu choices at the

top.  It’s really easy.

Give it a try!

14

SPM Tip - Create a Slide Show
 by Dennis Green

StereoPhoto Maker has a quick way to create a slideshow from

images in a folder.  The hard way would be to create copies of all of

the images you wanted in the show, put them in a folder and name

them so that they play in the correct order as you step through them

with SPM.  Instead, using the option of creating a slide show list,

you can pick and choose image from one or more folders, and

show them in any order without renaming or copying them.

The first step is to look through the images and decide which ones

you want in the show, and what order you want them to appear.

Then, while viewing them in SPM, when you get to the first image

for the show, just press the “M” key and a dialog box will open that

(1) shows the folder you are in, (2) asks you to name the list (give it

a name you will remember in case you end up with more than one

slideshow), and (3) specify how long you want each image to be

displayed in tenths of a second (so a duration of 50 will be five

seconds). After that, go through the folder , pressing “M” when you

see the next image you want in the show, and each will be added,
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SPM Quick Tip: First Steps
by Dennis Green

I remember when I first tried to use StereoPhoto Maker.  I went to

the website and downloaded the program and started it - then had

no idea what to do.  I was confronted by this black blank screen,

unlike other programs that would open with a blank document or a

work area.  So to get a beginner going, this article will start from the

very beginning and go through just the first two steps; downloading

the program and viewing some images.

Step 1: Download the program.

Go to the website that has a variety of Masuji Suto’s programs.  You

can use a web search on “StereoPhoto Maker” , or use this link:

http://stereo.jpn.org/eng/stphmkr/

A few lines down the page you will see the download links:

Download one of the versions  and open it (you may get a message

saying “unknown publisher” - run the program anyway).

Once the program opens, you will see a black screen with a few

icons at the top, plus some menus. Click on the first icon to open a

stereo image, like an mpo file from a stereo camera or a side-by-

side image from another source.

Click on the second icon to open

Left and Right images, like those

from a pair of cameras or two

images taken with a single camera

(cha-cha). These options are also

available from the File menu.

Step 2: View an image.  Now that you know how to open an

image, let’s look at the options for viewing one in 3D.
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window if the deviation is less than 1/25 of the image, which will

work for most images.  You can always adjust the window after the

alignment is done, so

this is more of a general

setting.  You can also

choose to not have the

window automatically

set.

Other options include

adding a little sharpening

(a little helps a lot) and doing an auto color adjustment if you have

two cameras that give different results - that will allow all of the

images to be matched to the better camera.  Save your adjusted

images to a different folder, and you can change settings and redo

the adjustments.

3. Edit the images:

The third category is the edit area.  You would most often use this to

do resizing of your images

(see the Quick Tips collection

in the “How To” section of the

club website for details).

Beyond that, there are several

added edits that will save a lot

of time over doing them on

each image.

One is to add a decorative border that you set up in “Border Op-

tions” under the View menu (or hit Alt-B).  Another is to swap all of

the L/R images, which is handy if you want to print out images for

free-viewing using the cross-view method.

You can also add a logo image (which could be a copyright notice)

or add generic text (like the author’s name or a generic caption like

“Scenes from Yellowstone - 2017”.

Try a few conversions in each category on a folder of images,

saving them to another location.  You may save hours of work and

make your picture processing faster and more fun!         [    ][    ]
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When you have a stereo image open, the menu options will expand,

giving you more tools. We will concentrate on the viewing options.

The first icon allows you to view the image in interlaced mode,

which would be used if you have a passive 3D display, such as a

3D laptop, 3D TV or passive monitor.  The settings for this mode

(or for any of the viewing icons) can be found under the Stereo

menu.  Once set, SPM will remember your setting.

If you don’t have a 3D display, you can use one of the next two icons

to view the image in anaglyph mode using glasses with the colored

lenses.  You have a choice of Gray Anaglyph, which will remove the

color from the image (useful when the image has a lot of red or cyan

colors in it), or color anaglyph.

The dropdown next to the Gray Anaglyph icon allows you to change

the anaglyph color to match your glasses.  The default is red/cyan,

which is the most common anaglyph colors, but you can use

glasses with red/green, red/blue, or yellow/blue, you can use them.

The dropdown next to the Color Anaglyph gives

you choices among several ways to view im-

ages to reduce the problems with red or cyan

colors in your images.  The best thing to do is to

start with color at the top, and try out the different

reduced color options to see which gives the

best view for you.

The next viewing options is side-by-side, the default viewing mode,

which can be used for free-viewing or with one of several mirror

viewing devices.  This icon is followed by the Above/Below mode

used with viewers like the View Magic.  This is good for viewing

panoramic images. The final two modes are for Sharp glasses-free

displays and for using shutter glasses, if you have that hardware.

Now that you have taken the first steps with SPM, look over the

other SPM Quick Tips (in newsletters or on the club website) and try

one of the other tips.  Before you know it, you will be using SPM for

most of your stereo viewing and editing.        [    ][    ]
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SPM Tip - Multi-Conversion
 by Dennis Green

Last month we showed several ways to open files in StereoPhoto

Maker.  This month we will show how to use Multi-Conversion to do

the most common tasks for a folder full of images.  The three main

categories are:

1. Change the file format:

Input:

The input format will normally be either side-by-side (.mpo or .jpg if

you are using a 3D camera like the Fuji W3 or Lumix 3D1) or

independent L/R images (if you are using a twin camera rig or

shooting cha-cha style). There are a few other choices in case you

are starting with files that are in another format, like anaglyph.

Output:

The output format has two main choices.  The first is file type (side-

by-side most often, but other choices are independent L/R, anag-

lyph, interlaced, half-width SBS for viewing on a 3D TV, etc.) . The

other is file extension (usually .jpg, but other choices include .tif, .jps,

and most important, .mpo for use with devices that automatically

recognize that .mpo implies a 3D image). You could also use this

area to separate stereo images into L/R files so you could send or

upload 2D images when a 3D viewing device is not an option.

2. Adjust the images:

SPM’s greatest tool is probably still the ability to automatically align

a folder full of 3D images with just a few mouse clicks.  The button

“Auto alignment Setting” allows you to determine how the alignment

should be done.  The most common choices are to mount the near

point to the window, or to set the far points to an infinity setting or

number of pixels.  The default is to mount the near point at the
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SPM Quick Tip: Opening Files
 by Dennis Green

Here are four tips on opening stereo files for viewing or editing

using StereoPhoto Maker:

1. To quickly open a 3D

.jpg file from Windows

Explorer, just right-click

on the filename and

hover over the “Open

with” option in the dialog

box. Another dropdown

will appear with options.

If SPM is not in the

options, just click on

“Choose default pro-

gram...” and it will allow

you to navigate to the

SPM program.  Once

you select SPM, it will

be added to the

dropdown for future use.

2. Youcan have an .mpo file

automatically open with SPM

instead of some 2D photo

viewer when you double-click

on the file. Just click on the

“Start” button and then on

“Default Programs”. Then click

on “Associate a file type...” and

wait for the list of file types to

appear. Select “.mpo” and then

click on the “Change Program”

button at the top. Some suggested programs will appear, or you

can navigate to SPM to make it the default. From then on, it will be

much faster than opening SPM and then finding a file.
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3. To have Windows Explorer show thumbnails of .mpo files instead

of just an icon, you can change your registry file so that Windows

will treat .mpo files just like .jpg files, allowing you to view their

thumbnails in Windows Explorer or any other program that can

open a .jpg image.  Full directions for making this change are on

Don Munsil’s website: http://www.munsil.com/MPO_registry.html.

4. SPM has a tool for viewing image

files in folders. It is the fourth icon

from the left  - the “Open Image File

List” command. Clicking on this icon

will give you a window similar to

Windows Explorer with two useful

functions for those who are using twin cameras (which is becoming

popular again) with pairs of Left and Right image folders.

The first function is that if you

have images from a camera

that is upside down in a twin

rig, you can reorient all of the

pictures for that folder by

selecting the Exif menu and

selecting “Set the orientation

tag 3 ‘180° rotated’ ”.  You will

then be able to see all of

those images right side up.

If you open another instance of the Image File List (by selecting the

“Instance” menu), you can view the contents of the other folder.  By

now using the “D” (down) and “U” (up) keys, you can scroll both

folders at the same time, which will allow you to find any orphan

images  before opening the files and making stereo pairs.

Once you have all the images in matched pairs, you can open them

by selecting one image from the left folder and one from the right,

then using the menu item “Open L/R Image” (or press the “O” key).

After one image is open, you can step through the other images by

just using the space bar.        [    ][    ]


